Cyrillic
1.1

Guide for
Demonstration Disk

Cyrillic is a program for drawing family trees and
managing pedigree data. It will be useful in hospitals
and laboratories where genetic information is handled
on a routine basis. The program is designed to work
with IBM PCs or compatibles running Windows 3.1
with at least 2 Mb of RAM.

The demonstration version of the program on the
accompanying disk is intended for evaluation purposes
only and has several limitations.

« There is a limit of 15 persons in a family (the full
application can handle up to 1,000 persons in a
single family).

- The options to save or import files have been
disabled.

« While a sample family can be printed, any printout
will bear a legend explaining that it comes from a
demonstration version of the program.
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« The full program is accompanied by a manual of 200
pages. This brief guide introduces you to some of
the key features and gives an indication of the
program's scope, but it is intended to give you a
glimpse rather than the full story.
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An Example
Family
Running the Cyrillic demonstration

To install the Cyrillic demonstration put the disk into
your disk drive and in the Windows Program Manager,
select the Run option from the File menu.

='| Run

Command Line:
|ﬁ:\59“‘p | Cancel I
D Run Minimized Browse__.

Type a:\setup in the dialog box and press <return>.
You will be asked to confirm the directory for
installation.

== |Installation of CYRILLIC for Windows 3.1c:\famtrees

Setup will install this application into the following
directory. which it will create on your hard disk.

If you want to install the application in a different directory
and/or drive, type the name of the directory below:

Copyto: |CAFAMTREES

| OK I ‘Qam:ell

Press <return> to accept the default directory unless
you wish to change it. The Cyrillic files will now be
copied to your hard disk and a program group and icon
will be created in the Windows Program Manager.

=| ovmuc [-[-

dc

CYRILLIC
pedigree
editar

To run the demonstration program double click on the
Cyrillic icon in the Windows Program Manager.

On your demonstration disk you will find a sample
family 'DMDTest5.fam'. Select the file by choosing
Open from the File menu. We will now guide you
through some features of Cyrillic, but if you are
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confident with Windows programs why not explore the
family yourself through the menus and the tool bar?

| |v|A

CYRILLIC - [CAFAMTREES\DMDTE ST5.FAM]

File Edit Options Format Inputioutput Windows Help

First, let us take a look at the menu system. The main
headings: File, Edit, Options, Format, Input,
Windows and Help group the principal functions of
the program. Pull down the Edit menu and choose the
Family Information option. You will see a dialog box
with various items of information, for example that this
is a family with Duchenne Muscular Dystrophy. Note
that there are several areas in the dialog box where
you can enter additional data.

|

Family identity information

Family ID number : | DMD 5

| ‘Cancelll 0K I

Family name : |

Selectfamilymarkersl Num indidividuals in family : 11

Max Num Individuals: 1000

Family condition : |Duchenne muscular dystrophy (Aff) |

Guantitative value : |

[

Comments: |0-011

t

+

Date of original information :

Date of last update :

]
L]

Now take a look at the Input/output and the Help
options. If you experiment with the Windows menu
you will find that you can change the tool bar into a
floating palette which can be moved around your
family tree. This is particularly useful when working
with large families. Let us now use some of these

tools.

First a general hint. Cyrillic works on the
Object/Action principal. You select an individual or a
group of individuals (the Object) and then you apply
some Action to your selection. These actions are
grouped in the menus and can also be invoked by
clicking on the buttons in the tool bar. A second hint.
You select an individual by pointing to it with the
mouse and clicking with the left mouse button. If you
want to select more than one individual, or an area
from a family tree, hold the mouse button down and
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Editing Patient
Data

drag across your tree. Try this technique to select two
or three individuals and then apply one of the tools to
your selection by clicking the relevant button (try
'‘Marker', 'Spouse' or 'Ind Dat'). Notice that you cycle
through the individuals you have selected and at each
stage you can change data associated with the
individuals by typing in the dialog boxes. As you work
with Cyrillic you will find that there are plenty of short-
cuts and some of these are mentioned on the menu.

You may nowlike to explore the family by using some of
the tools. Select a married individual and click on the
'Spouse’ button. You will find a 'Partnerships' dialog
box, which you can use to change the 'kind of
relationship’ to 'separated' or 'divorced' (click in the
check boxes). Notice what effect this has on the family
tree. Now select an individual by clicking on the 'Ind
dat' button.

=‘ Individual data form

Other ‘O Normal |£I
ssssssss : -Cant:el
F . Genetic bols :

eeeeeeeee \—I ‘O Clear symbaol EI
Known as : Additional symbals :
Maiden name : ‘ O Clear symbol |£I

Address

Py .
- Multiple .. |Singleton .
pregi :

Additional info: 2 Liability class : I:lzl

New line = 1

Ctrl+Enter +
o .

Male ® Female O Sex unknown
Pedigree number : II:4
3 [ Disconne ct from parents

Date of Date of Additional data...| Identifier :
birth : ‘ ‘ death : ‘ ‘ ‘ I l:l

O Proband 1 Al markers unknown [J Adopted [ Possibly adopted

Change the Genetic Symbol representing the individual
by selecting one from the scrollable list in the dialog
box.
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Drawing a new

family
=‘ Individual data form
Sumame: [ | [s]Pregnancy outcomes :
ssssssss : Cancel
F . Genetic bols :
nnnnnnnnn \—I < Clear symbuol
Known as : l:l O Clear symbol 54
@ Unaffected L
Maiden name : ‘ | ® A o
Add : @ Heterozygous
@ Possibly affected :El
& ql
Additional info: @ a2
New lin: v q3
Ctrl+Enter o g4
C H @ ql +q2
@ ql+q3
o ql+q4
[ Disconne ct from parents
Date of Date of Additional data...| Identifier :
birth : ‘ ‘ death : ‘ ‘ ‘ I l:l
[ Proband O All markers unknown [ Adopted [ Possibly adopted

Next, select an individual and use the 'hide' or 'desc'
buttons to see what you can do with these buttons.
When you have performed an action with these tools
you can use Display full family in the Options menu
to return to the full family tree. Finally, try moving
some of the individuals on the tree. Point to an
individual with the mouse and drag the person, with
the mouse button depressed, to a new location. You
may also move a portion of the family tree by selecting
some part of it and dragging the highlighted rectangle
to the new location. The ability to move individuals or
branches of the tree, by pointing and clicking is very
handy when you need to make additions to a family.
Before we draw a family from scratch try
experimenting with some of the menu options and tools
on the tool bar. Note that often additional features are
available by using the right mouse button.

Now that you have taken a general look at the
program, this section provides a step-by-step guide to
producing a simple drawing. To draw a pedigree for a
new family, select the New option from the File menu.
If you are already working on a drawing, you will be
asked whether you want to store this information.
Since saving is disabled in this demonstration version
of Cyrillic, select the No button in the dialog box. The
screen will then be cleared and the 'Family identity
information' dialog box will be displayed.
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= Family identity information

Family 1D number : ‘0| | |Cance||| ok_|

Family name : ‘ |

Selectfamilymarkersl Num indidividuals in family: 0

Max Num Individuals: 1000

Family condition : ‘ ‘
Quantitative value : ‘ EI
Comments : i

+

Date of original information : I:|
Date of last update : l:l

Once you have entered any information on the family,
click on the OK button. Position the cursor where you
want the first individual to appear on screen and click
on the left mouse button for a female or the right
button for a male. The 'Individual data form' dialog
box appears.

=‘ Individual data form
surnames : Cancel
F . Genetic symbols :
orenames - ‘ O Clear symbol |£I
Known as : Additi 1 bol
Y
Maiden name : ‘ | ‘O Clear symbol |EI
Address : + i
O Multiple .. |Singleton
preg :
Additional info: *! Liability class : |:E|
New line = 1
Ctrl+Enter +
C : + +
> Male ‘® Female < Sex unknown
Pedigree number : II:4
5 [J Disconnect from parents
Date of Date of Additional data...| Identifier :
b - | | ot | | | | L]
[ Proband 1 & markers unknown [0 Adopted [ Possibly adopted

Enter any information on the first individual and
choose OK. The first symbol is displayed on screen.
You can now enter family members related to this
person. Position the cursor over the symbol and click
the right mouse button. The 'Relationship of new
individual' dialog box now appears.
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Further
explorations
=-‘ Relationship of new individual
Select the relationship of the new
individual to their relative.
[ Motner | | Father | | wie | [Husband |

|§,}_emgmsw| ‘ $60 | ‘ Ssler | ‘ Bm%?z@{'l

Pariner et Sibding
| | | |

|M€>iz{>zyg§<sasxiwiiz| ‘ Drygous bin | ‘ Py 727 |

| Trigsiet H Gundrupiet H Guintuniet |

Sexduplel
| Unconnected individual | Cancel I

Click on the button for the appropriate relationship.
This removes the dialog box and changes the cursor to
indicate that you are entering a new relation. Position
the cursor where you want the symbol to appear and
click the left mouse button. You will now be presented
with another 'Individual data form' dialog box for the
new relation. Enter any relevant information and click
on the OK button. The new symbol will be displayed
on the screen with a line joining it to the first individual
you entered.

=] CYRILLIC - [NoName] v|a
File Edit Options Format Inputfoutput Windows Help

* +

You can now draw the rest of the family using the same
principles, remembering that the demonstration
version allows a maximum of 15 individuals.

Cyrillic has far too many features to be described in
detail in a short guide like this. Please experiment with
the various options on the Format menu to discover
how virtually every aspect of the drawing can be
controlled to match your particular needs. Look also at
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the Edit menu options Edit Markers and Edit
Diseases to examine the facilities Cyrillic offers for

defining and recording disease and marker

information.

CYRILLIC- [CACYRILLIC\FAMTREE S\EX3.FAM]

File Edit Options Format Inputioutput Windows Help

=-‘ List of disease loci

Disease name :

Becker Muscular Dystrophy (Quan)
Coronary disease

Cystic Fibrosis

Duchenne muscular dystrophy
Duchenne muscular dystrophy (Aff)
Duchenne muscular dystrophy (Quan)
Fra(X) Mental Retardation
Huntington's disease

LDL Cholesterol levels

Norries disease

Oto-palato-digital syndrome |

Edit... I

Reads BMD

Reads L{ = Information about a disease
Spinal m|

Spinal m| Duchenne muscular dystrophy (Aff)
Test disq

@ Affection O Quantitative

Frequency of disease allele : | 0.000200

Chromosome :
0.000100
0.000100

Male mutation rate :

Female mutation rate :

[ Set default markers for disease I
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The ideal tool
for creating
family trees

and managing
genetic
information

Cyrillic

We think you'll agree that Cyrillic is the most user-
friendly and powerful pedigree drawing software on
the market. We believe that Cyrillic and Microsoft
Windows provide a winning combination of simplicity,
publication-quality output, and powerful information
management tools.

Cyrillic comes with a comprehensive user manual. This
includes a tutorial, and detailed chapters on pedigree
drawing, adding data, genetic markers, importing files,
and outputting data to linkage analysis programs.

If you have any technical questions about Cyrillic ring
Cherwell at any of the numbers below.

Don't you wish you were using Cyrillic today?
Telephone, fax, or send your order direct to Cherwell
Scientific at one of the following addresses.

Cherwell Scientific Publishing Cherwell Scientific
Ltd Publishing
c/o CHEM Research
GmbH
Beethovenstralse 7 B
D-60325 Frankfurt
Germany

Tel: 069-7411114
Fax: 069-740496
The Magdalen Centre
Oxford Science Park
Oxford OX4 4GA
United Kingdom

Tel: +44 (0)1865 784800
Fax: +44 (0)1865 784801
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Internet: csp@sable.ox.ac.uk

Cherwell Scientific Publishing,
Inc

744 San Antonio Road

Palo Alto

CA 94303

Tel: (415) 852 0720

Fax: (415) 852 0723
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